+1
Fixed

MP3 uploading broken

Dermot Mac Flannchaidh 3 years ago updated by Digby (Community Manager) 2 years ago 28

Currently I'm not able to upload any MP3 file. It uploads up to 100%, then is rejected with "File type not allowed" message. I tried one MP3 repeatedly, then a different one repeatedly, no dice. Then I tried an MP3 I had already successfully uploaded before, and it gave me the same error message. None of these MP3s are over 10MB, as I previously successfully published them on my FurAffinity account.

All right... I see that other users have been able to upload MP3s successfully recently. I tried again, but it still rejected my upload as "File type not allowed." This is the file I keep trying and failing to upload. I've tried others too with the same error.


https://dl.dropboxusercontent.com/u/109661622/Funky%27s%20Fugue%20%28VRC6%29%20NSF.mp3


I've tried uploading in both Chrome and Firefox. Same error.

+1
Under review

Can you tell me how are you encoding your MP3s?

I'm encoding them with a commandline encoder called LAME. It's pretty common. Then I open the MP3 in winamp and edit the ID3v2 tags. Note that I was already able to upload six MP3s (my Star Fox chiptune recordings) which were encoded and tagged the same way.

If you want specific commandline switches, I do:

lame -V0 whateverfilename.wav

It outputs whateverfilename.mp3. The encoder's homepage is here:

http://lame.sourceforge.net/

+1

Can you open up the Developer Console in Chrome, go through the process of uploading a file, and send in a screenshot of any errors that are listed in the Console?

+1

Hey there - I was actually able to grab your file and replicate the error here. I've passed the errors and your file onto our developers for review.

Do you still want me to do the Developer Console thing for corroborating info?

Okay, here. By the way, thank you for taking the time to look into this bug report. It's been frustrating me for a week.

+1

Thanks for that! And sorry that it's taken so long to look into this - we've been a little busy.

Understandably. The FurAffinity hiccup must have made things interesting.

I've been reattempting uploads pretty much every day. I can confirm it's still broken. Should I wait another week or so? I'm a bit anxious for the opportunity to keep posting music.

+1

I'll check on the status of a fix - please be patient!

Yes, I've been trying to be. I just don't know whether I should reasonably wait a week or a month.

Still not working after another week. I wonder - could it have anything to do with the MP3 being variable bit rate (VBR)? I was able to successfully upload them before, but the same files fail now. Maybe something was broken server-side by mistake.

+1

I believe this is currently on our to-do list to fix.

Just a little longer, it will most likely be pushed with next bigger update.

Uploads still not working. Same issue. Same error. No change.


You know, I understand the site is still in beta, and not everything is necessarily expected to work properly until the beta phase is over. I've been involved in software development before, so I get that. And I know music features may be considered a much lower priority on a site like this


But I sort of hoped that a feature already advertised to work would actually work as advertised, especially considering it previously worked and I have existing uploads that attest to that. If the feature is partially broken, maybe it's best to label it in the upload interface as "experimental" or "buggy" or something similar until it's properly fixed.

Update: Uploads still not working. Same issue. Same error. No change.

Update: Ditto. Ditto. Ditto. Ditto.

+1

We are still here!

It may take a moment to fix, but we are making sure all the bugs (and suggestions) are noted and we'll get to them as soon as possible. :)

Update: Ditto. Ditto. Ditto. Ditto. Again.

+1
Planned

Dermot, the biggest problem is that our development team has had development on hold for several months. We've started back up, but there are many more issues that need to be addressed first. With that said, the way you can get MP3s to work is to save them without ID3 tags. If you're not able to do that, there are programs across the internet that can be used to remove those tags.


Here's your file with the tags removed: https://www.dropbox.com/s/pmb6xey9dvi12xm/Funky%27s%20Fugue%20%28VRC6%29%20NSF.mp3?dl=0


I hope this helps. Please let me know if you have any questions.

Thanks for your response. Sorry for my own delay.


I appreciate that you've found this workaround, which I'm sure will be helpful to music publishers on FN. But with all due respect, I use ID3 tags to sign my work and provide basic information about a song to maintain a chain of attribution. I don't want to publish my arrangements without tags.

+1

I understand, Dermot. It makes sense that you'd want to have that information on a song - I've come across songs before where I didn't know the musician, and that would have made a difference. I've put this on a list of our needed fixes. We're going through commission testing right now, but as soon as we have any coding changes rolled out, I'll have the dev team look at this to see if we can get this fixed, as well.

Thank you. I appreciate any time and effort the team can provide towards fixing the bug.

Fixed

This has been a bit of a long journey, but the release today should fix the MP3 ID3 issue. You should be able to upload those files now. Please let me know if you run into any difficulties.